Logitech Quickcam Pro 9000 - capture settings

Oct 8, 2009 at 12:50 PM
Edited Oct 8, 2009 at 12:52 PM


First of all thanks for you great work here. I've tried a couple of libraries to capture a video of my webcam - and mediakit is my favorite.

I still have only one problem:

I can't capture in the highest resolution (1600x1200 16bit 5fps YUV2) using my Logitech Quickcam Pro 9000.

I used the following settings:


The second best (960x720 24bit 15fps MJPG)


shows only some weird colors.

Is there a hint how I can fix this?

Btw: is there an easy way to show the capabilities of a capture device?

Thanks in advance


Oct 8, 2009 at 2:15 PM
Thats nice of you to say!  Thank you!  A lot of hard work went in to this lib.

Anyways, try grabbing the newest source.  I have the same webcam and can do both those resolutions.

I only have support for the property page of the camera.  You can use it like this:

<Button Content="Properties"
                        Command="Controls:VideoCaptureElement.ShowPropertyPagesCommand" CommandTarget="{Binding ElementName=videoElement}" />

There is an example in the sample application "WebCamPlayerWindow.xaml"

Let me know if you have any issues.  I"m going to be doing a few more updates in the following days.  So keep a look out :)
Oct 8, 2009 at 2:40 PM
Edited Oct 8, 2009 at 2:41 PM

Thanks for your quick reply. I tried your sample app (using the latest version) but it's the same here. I attached a screenshot. The only thing I changed were the capture settings in the xaml.

<Controls:VideoCaptureElement DesiredPixelWidth="1600" DesiredPixelHeight="1200" FPS="5" ...

I attached a screenshot of the program (I'm running XP).

If you have any further idea what I could try - just tell me.


Oct 8, 2009 at 3:00 PM
I really havent tested on XP at all ;)

Does setting the UseYuv = true change anything?
Oct 8, 2009 at 3:12 PM

here we go - that was the right switch - it's looking great now

I sent the old biniares (not workung under XP) to a friend of mine having the same camera using Vista. There's not the issue above. It seems to be dependent on the OS.

thanks a lot

Oct 8, 2009 at 4:53 PM

I just installed the logitech software for the webcam and guess what? It's working even without the UseYuv setting....