COM error when creating the GraphBuilder

Jul 12, 2013 at 6:31 PM
Edited Jul 12, 2013 at 7:01 PM
Just came across this issue which suddenly started happening consistently. It will not play any videos at all. I have yet to determine if this is an unrelated OS issue, or if it could be related to MediaKit in some way (by either my mistake, or a bug).

Error:
System.IO.FileNotFoundException: Retrieving the COM class factory for component with CLSID {E436EBB8-524F-11CE-9F53-0020AF0BA770} failed due to the following error: 8007007e The specified module could not be found. (Exception from HRESULT: 0x8007007E).
at WPFMediaKit.DirectShow.MediaPlayers.MediaUriPlayer.OpenSource()

Specifically it throws the exception at the following line:
m_graph = new FilterGraphNoThread() as IGraphBuilder;
I've reinstalled my codecs twice and I'm about to reformat to at least get it working. I booted up my Win 8 VM and it worked. I also tried to repro this on 2 other machines. No issues on one, but it happened on the other.

Update: that CLSID is in reference to quartz.dll, which I do have. Any suggestions on tools to dig deeper into this?