multiple sound cards

May 3, 2010 at 2:14 AM

Hi Jer

I am almost there ... just a couple of issues...

1:  I cannot set the audio to play through a different sound card other than the default ... i have set the audiorenderer property and test the property before and after.. before it is the defualt after it is the device i have selected.

2: every now and then the video clips get horizontal like tearing through them especially during a big scene change or when there is lots of mevement.

Thanks in advance

David

May 3, 2010 at 2:20 AM
If you can step into the MediaKit source, try adding a breakpoint at MediaUriPlayer::InsertAudioRenderer and see what is happening.  It's a fairly simplistic operation in terms of DShow API, so it could be some bug in my code you are hitting.

As for the tearing, I've only seen tearing on XP machines or Vista/7 machines with Aero (DWM) off.  In one case, it was just video card drivers.  What operating system are you using?

-Jer
May 3, 2010 at 2:57 AM

it is xp pro service pack 3... how do i check the aero settings?

 

May 3, 2010 at 3:01 AM
Aero only exists in Vista and Windows 7.  Aero (DWM) is the d3d hardware accelerated desktop.  It manages things globally like syncing with the monitor redraw so tearing doesn't occur.

 The unfortunate thing, is video tearing is a known issue with XP.  If new drivers/GPU don't fix the issue I'm unsure how to resolve it...

-Jer
May 3, 2010 at 3:08 AM

a little bit more info

Windows XP Service Pack 3

Intel Core 3 530 @ 2.93 Ghz

2 GB Ram

2 * Asus EAH4350 Video Cards 512MB

 

May 3, 2010 at 3:09 AM

thanks i will try a different more betterer video card...